Degraded performance in Business NXT

Incident Report for Visma Cloud Services

Resolved

The issue is now resolved and the service is up and running as normal.
Posted Oct 16, 2025 - 10:53 CEST

Monitoring

The performance of the Business NXT application has been reduced in the last 20-25 minutes. The issue should be solved, but we will keep monitoring to ensure high quality.
Posted Oct 16, 2025 - 10:22 CEST
This incident affected: Business NXT (Business NXT ERP).