Downgraded performance for some customers in Visma Net ERP

Incident Report for Visma Cloud Services

Postmortem

Problem was caused by a query that was executed on one of our SQL servers. All customers that were on the same server were impacted by the slowness. We have now improved the functionality related to the query to prevent similar issue from happening in the future.

Posted May 20, 2026 - 11:26 CEST

Resolved

This incident has been resolved.
Posted May 11, 2026 - 16:35 CEST

Monitoring

Performance is normal again, we continue to monitor the situation
Posted May 11, 2026 - 15:00 CEST

Update

We are now upscaling our resources for the server with lower performance.
Posted May 11, 2026 - 14:42 CEST

Identified

Some customers, belonging to the same server, are experiencing a slower performance.

We have identified the problem. There is one customer that are making a lot of calls when trying to connect via API. We are reaching out to the customer.
Posted May 11, 2026 - 13:14 CEST
This incident affected: Visma Net (Visma Net).