Investigating an issue in PowerOffice Go

Incident Report for Visma Cloud Services

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 22:05 CET

Monitoring

All services are up and running again. We will keep monitoring.
Posted Oct 29, 2025 - 21:52 CET

Update

New estimates from Microsoft says that they expect all services to be recovered by 23.20 UTC.
Posted Oct 29, 2025 - 21:11 CET

Identified

The issue has been identified and we are awaiting updates from Microsoft
Posted Oct 29, 2025 - 19:29 CET

Investigating

We are currently investigating an issue in PowerOffice Go. The issue is part of a wider Microsoft Azure issue that is affecting other services using Microsoft Azure.
Posted Oct 29, 2025 - 17:10 CET
This incident affected: PowerOffice Go.